Initial import
[airlibre] / composer.json
1 {
2 "type": "project",
3 "name": "rapsys/airlibre",
4 "description": "Open air booking system",
5 "license": "AGPL-3.0-or-later",
6 "require": {
7 "php": "^7.1.3",
8 "ext-ctype": "*",
9 "ext-iconv": "*",
10 "rapsys/packbundle": "dev-master",
11 "rapsys/userbundle": "dev-master",
12 "rapsys/airbundle": "dev-master",
13 "symfony/console": "4.3.*",
14 "symfony/dotenv": "4.3.*",
15 "symfony/flex": "^1.3.1",
16 "symfony/framework-bundle": "4.3.*",
17 "symfony/process": "4.3.*",
18 "symfony/security": "4.3.*",
19 "symfony/yaml": "4.3.*"
20 },
21 "require-dev": {
22 },
23 "config": {
24 "preferred-install": {
25 "*": "dist"
26 },
27 "sort-packages": true
28 },
29 "autoload": {
30 "psr-4": {
31 "App\\": "src/"
32 }
33 },
34 "autoload-dev": {
35 "psr-4": {
36 "App\\Tests\\": "tests/"
37 }
38 },
39 "replace": {
40 "paragonie/random_compat": "2.*",
41 "symfony/polyfill-ctype": "*",
42 "symfony/polyfill-iconv": "*",
43 "symfony/polyfill-php71": "*",
44 "symfony/polyfill-php70": "*",
45 "symfony/polyfill-php56": "*"
46 },
47 "repositories": [
48 {
49 "type": "package",
50 "package": {
51 "name": "rapsys/userbundle",
52 "version": "dev-master",
53 "source": {
54 "type": "git",
55 "url": "https://rapsys@git.rapsys.eu/userbundle",
56 "reference": "master"
57 },
58 "autoload": {
59 "psr-4": {
60 "Rapsys\\UserBundle\\": ""
61 }
62 }
63 }
64 },
65 {
66 "type": "package",
67 "package": {
68 "name": "rapsys/packbundle",
69 "version": "dev-master",
70 "source": {
71 "type": "git",
72 "url": "https://rapsys@git.rapsys.eu/packbundle",
73 "reference": "master"
74 },
75 "autoload": {
76 "psr-4": {
77 "Rapsys\\PackBundle\\": ""
78 }
79 }
80 }
81 },
82 {
83 "type": "package",
84 "package": {
85 "name": "rapsys/airbundle",
86 "version": "dev-master",
87 "source": {
88 "type": "git",
89 "url": "https://rapsys@git.rapsys.eu/airbundle",
90 "reference": "master"
91 },
92 "autoload": {
93 "psr-4": {
94 "Rapsys\\AirBundle\\": ""
95 }
96 }
97 }
98 }
99 ],
100 "scripts": {
101 "auto-scripts": {
102 "cache:clear": "symfony-cmd",
103 "assets:install --symlink --relative %PUBLIC_DIR%": "symfony-cmd"
104 },
105 "post-install-cmd": [
106 "@auto-scripts"
107 ],
108 "post-update-cmd": [
109 "@auto-scripts"
110 ]
111 },
112 "conflict": {
113 "symfony/symfony": "*"
114 },
115 "extra": {
116 "symfony": {
117 "allow-contrib": false,
118 "require": "4.3.*"
119 }
120 }
121 }