Fix filters structure
[packbundle] / README.md
1 Installation
2 ============
3
4 Applications that use Symfony Flex
5 ----------------------------------
6
7 Add bundle custom repository to your project's `composer.json` file:
8
9 ```json
10 {
11 ...,
12 "repositories": [
13 {
14 "type": "package",
15 "package": {
16 "name": "rapsys/packbundle",
17 "version": "dev-master",
18 "source": {
19 "type": "git",
20 "url": "https://git.rapsys.eu/packbundle",
21 "reference": "master"
22 },
23 "autoload": {
24 "psr-4": {
25 "Rapsys\\PackBundle\\": ""
26 }
27 }
28 }
29 }
30 ],
31 ...
32 }
33 ```
34
35 Then open a command console, enter your project directory and execute:
36
37 ```console
38 $ composer require rapsys/packbundle dev-master
39 ```
40
41 Applications that don't use Symfony Flex
42 ----------------------------------------
43
44 ### Step 1: Download the Bundle
45
46 Open a command console, enter your project directory and execute the
47 following command to download the latest stable version of this bundle:
48
49 ```console
50 $ composer require rapsys/packbundle dev-master
51 ```
52
53 This command requires you to have Composer installed globally, as explained
54 in the [installation chapter](https://getcomposer.org/doc/00-intro.md)
55 of the Composer documentation.
56
57 ### Step 2: Enable the Bundle
58
59 Then, enable the bundle by adding it to the list of registered bundles
60 in the `app/AppKernel.php` file of your project:
61
62 ```php
63 <?php
64 // app/AppKernel.php
65
66 // ...
67 class AppKernel extends Kernel
68 {
69 public function registerBundles()
70 {
71 $bundles = array(
72 // ...
73 new Rapsys\PackBundle\RapsysPackBundle(),
74 );
75
76 // ...
77 }
78
79 // ...
80 }
81 ```