5 override_dh_installman
:
6 pod2man
-r
"youtube-dl" -c
"User commands" debian
/youtube-dl.pod
> debian
/youtube-dl
.1
11 override_dh_pysupport
:
14 FULL_VERSION
:= $(shell dpkg-parsechangelog | grep ^Version
: | sed
-e
's/^.*: //g')
15 TAR_VERSION
:= $(shell echo
$(FULL_VERSION
) | sed
-e
's/-.*//g')
16 SOURCE
:= $(shell dpkg-parsechangelog | grep ^Source
: | sed
-e
's/^.*: //g')
18 ORIGDIR
= $(SOURCE
)-$(TAR_VERSION
)
19 TARNAME
= $(SOURCE
)_
$(TAR_VERSION
).orig.
tar.gz
23 mkdir
-p repack
/$(ORIGDIR
)
25 uscan
--noconf
--force-download
--rename
--download-current-version
--destdir
=repack
/
26 cd repack
; tar zxf
$(TARNAME
)
28 # Remove problematic files
29 rm -f repack
/$(ORIGDIR
)/youtube-dl.exe
31 tar -C repack
--numeric-owner
--owner
0 --group
0 -czf ..
/$(TARNAME
) $(ORIGDIR
)