]> Raphaƫl G. Git Repositories - youtubedl/blob - debian/rules
Merge tag 'upstream/2012.12.11'
[youtubedl] / debian / rules
1 #!/usr/bin/make -f
2 %:
3 dh $@
4
5 override_dh_installman:
6 pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
7 dh_installman
8
9 override_dh_python2:
10
11 override_dh_pysupport:
12
13
14 FULL_VERSION := $(shell dpkg-parsechangelog | grep ^Version: | sed -e 's/^.*: //g')
15 TAR_VERSION := $(shell echo $(FULL_VERSION) | sed -e 's/-.*//g')
16 SOURCE := $(shell dpkg-parsechangelog | grep ^Source: | sed -e 's/^.*: //g')
17
18 ORIGDIR = $(SOURCE)-$(TAR_VERSION)
19 TARNAME = $(SOURCE)_$(TAR_VERSION).orig.tar.gz
20
21 get-orig-source:
22 rm -rf repack
23 mkdir -p repack/$(ORIGDIR)
24
25 uscan --noconf --force-download --rename --download-current-version --destdir=repack/
26 cd repack; tar zxf $(TARNAME)
27
28 # Remove problematic files
29 rm -f repack/$(ORIGDIR)/youtube-dl.exe
30
31 tar -C repack --numeric-owner --owner 0 --group 0 -czf ../$(TARNAME) $(ORIGDIR)
32 rm -rf repack