]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
d/rules: Run offline tests.
[youtubedl] / debian / rules
index 870096940b3c124ddca977ba9296b502ad0ff962..e1e9a31437d6d1d4a3eda5e3016d0ae1dd753520 100755 (executable)
@@ -1,31 +1,21 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@ --with python2 --buildsystem=python_distutils
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
 override_dh_auto_configure:
        PREFIX=/usr SYSCONFDIR=/etc make
-       mv Makefile Makefile.inactive
        rm youtube-dl
 
-override_dh_install:
-       mv debian/youtube-dl/usr/etc debian/youtube-dl/
-#      # For the future (similarly for fish):
-#      # dpkg-maintscript-helper rm_conffile /etc/youtube-dl.bash-completion \
-#      #   etc.
-#
-#      mv debian/youtube-dl/usr/etc/bash_completion.d/youtube-dl.bash-completion \
-#              debian/usr/share/bash-completion/completions/youtube-dl
-       dh_install
-
-override_dh_installdocs:
-       dh_installdocs
-       mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
-       rmdir debian/youtube-dl/usr/share/doc/youtube_dl
-
 override_dh_clean:
-       -mv Makefile.inactive Makefile
-       -make clean
+       make clean
        dh_clean
-       rm -rf youtube_dl.egg-info
 
 override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+       make offlinetest PYTHON=python3
+endif