]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
d/rules: Run offline tests.
[youtubedl] / debian / rules
index 504e3570fc9b5df3cb3a4e906663cb3df6e6ecca..e1e9a31437d6d1d4a3eda5e3016d0ae1dd753520 100755 (executable)
@@ -1,32 +1,21 @@
 #!/usr/bin/make -f
-%:
-       dh $@
-
-override_dh_installman:
-       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-       dh_installman
-
-override_dh_python2:
-
-override_dh_pysupport:
 
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
 
-FULL_VERSION   := $(shell dpkg-parsechangelog | grep ^Version: | sed -e 's/^.*: //g')
-TAR_VERSION    := $(shell echo $(FULL_VERSION) | sed -e 's/-.*//g')
-SOURCE         := $(shell dpkg-parsechangelog | grep ^Source: | sed -e 's/^.*: //g')
-
-ORIGDIR        = $(SOURCE)-$(TAR_VERSION)
-TARNAME        = $(SOURCE)_$(TAR_VERSION).orig.tar.gz
-
-get-orig-source:
-       rm -rf repack
-       mkdir -p repack/$(ORIGDIR)
+%:
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-       uscan --noconf --force-download --rename --download-current-version --destdir=repack/
-       cd repack; tar zxf $(TARNAME)
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       rm youtube-dl
 
-       # Remove problematic files
-       rm -f repack/$(ORIGDIR)/youtube-dl.exe
+override_dh_clean:
+       make clean
+       dh_clean
 
-       tar -C repack --numeric-owner --owner 0 --group 0 -czf ../$(TARNAME) $(ORIGDIR)
-       rm -rf repack
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+       make offlinetest PYTHON=python3
+endif