X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/0f745d6e3e97ec27a41ad0522967db47eed9a43e..6d835d4d6903cf5e18ad01844736929e06d16004:/debian/rules

diff --git a/debian/rules b/debian/rules
index dcb746e..07d43f2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,34 +1,16 @@
 #!/usr/bin/make -f
 %:
-	dh $@
+	dh $@ --with python2 --buildsystem=python_distutils
 
-override_dh_installman:
-	pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	dh_installman
+override_dh_install:
+	mv debian/youtube-dl/usr/etc debian/youtube-dl/
+	dh_install
 
-override_dh_python2:
+override_dh_installdocs:
+	dh_installdocs
+	mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
+	rmdir debian/youtube-dl/usr/share/doc/youtube_dl
 
-override_dh_pysupport:
-
-
-FULL_VERSION	:= $(shell dpkg-parsechangelog | grep ^Version: | sed -e 's/^.*: //g')
-TAR_VERSION	:= $(shell echo $(FULL_VERSION) | sed -e 's/-.*//g')
-SOURCE		:= $(shell dpkg-parsechangelog | grep ^Source: | sed -e 's/^.*: //g')
-
-ORIGDIR	= $(SOURCE)-$(TAR_VERSION)
-TARNAME	= $(SOURCE)_$(TAR_VERSION).orig.tar.gz
-
-get-orig-source:
-	rm -rf repack
-	mkdir -p repack/$(ORIGDIR)
-
-	uscan --noconf --force-download --rename --download-current-version --destdir=repack/
-	cd repack; tar zxf $(TARNAME)
-
-	# Remove problematic files
-	rm -f repack/$(ORIGDIR)/youtube-dl.exe
-
-	tar -C repack --numeric-owner --owner 0 --group 0 -czf ../$(TARNAME) $(ORIGDIR)
-	rm -rf repack
-
-override_dh_auto_test:
+override_dh_clean:
+	dh_clean
+	rm -rf youtube_dl.egg-info