X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/1bca0e8d562d030d801aba62750fd7b77afe6f5a..96981814751d51f37fe7347060de3a51c982f5ec:/debian/rules

diff --git a/debian/rules b/debian/rules
index 93706fc..e1e9a31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,21 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@ --buildsystem=python_distutils
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	rm youtube-dl
+
+override_dh_clean:
+	make clean
+	dh_clean
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+	make offlinetest PYTHON=python3
+endif