X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/20139be603ee4ddc72dfcefb9c474c730b57636a..51777f15c62f5d8b31dba69f7f3683d30f99f32d:/debian/rules

diff --git a/debian/rules b/debian/rules
index f0c8e34..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,20 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
+
+override_dh_clean:
+	test -f Makefile || mv Makefile.inactive Makefile
+	make clean
+	dh_clean
 
-override_dh_installman:
-	pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	dh_installman
+override_dh_auto_test: