X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/2c7340935c5a1d278a0d4b141b0e27b4c3218946..eb315943b48443a3fe1fbabb0c0bab91f96f5b82:/debian/rules?ds=inline

diff --git a/debian/rules b/debian/rules
index 9031782..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,33 +1,20 @@
 #!/usr/bin/make -f
 
-build:
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
 
-clean:
-	dh_testdir
-	dh_clean 
+%:
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-install: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k 
-	dh_installdirs
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-	install -m 0755 $(CURDIR)/youtube-dl $(CURDIR)/debian/youtube-dl/usr/bin
+override_dh_clean:
+	test -f Makefile || mv Makefile.inactive Makefile
+	make clean
+	dh_clean
 
-binary-indep: build install
-
-binary-arch: build install
-	dh_testdir
-	dh_testroot
-	dh_installchangelogs 
-	dh_installdocs
-	dh_installman $(CURDIR)/debian/youtube-dl.1
-	dh_compress
-	dh_fixperms
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: