X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/4495cd37a803d1de6cb9d7d434ced5e72d773b2d..616c3801143a60e5ae8f3b57cc5826f7c8e5a5ad:/debian/rules

diff --git a/debian/rules b/debian/rules
index 70f28e1..8700969 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,34 +1,31 @@
 #!/usr/bin/make -f
+%:
+	dh $@ --with python2 --buildsystem=python_distutils
 
-build: build-stamp
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-build-stamp:
-	pod2man -n YOUTUBE-DL -c "User Commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	touch $@
-
-clean:
-	dh_testdir
-	dh_clean build-stamp debian/youtube-dl.1
-
-install: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k 
+override_dh_install:
+	mv debian/youtube-dl/usr/etc debian/youtube-dl/
+#	# For the future (similarly for fish):
+#	# dpkg-maintscript-helper rm_conffile /etc/youtube-dl.bash-completion \
+#	#   etc.
+#
+#	mv debian/youtube-dl/usr/etc/bash_completion.d/youtube-dl.bash-completion \
+#		debian/usr/share/bash-completion/completions/youtube-dl
 	dh_install
 
-binary-arch:
-binary-indep: build install
-	dh_testdir
-	dh_testroot
-	dh_installchangelogs 
+override_dh_installdocs:
 	dh_installdocs
-	dh_installman debian/youtube-dl.1
-	dh_compress
-	dh_fixperms
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+	mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
+	rmdir debian/youtube-dl/usr/share/doc/youtube_dl
+
+override_dh_clean:
+	-mv Makefile.inactive Makefile
+	-make clean
+	dh_clean
+	rm -rf youtube_dl.egg-info
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: