X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/4495cd37a803d1de6cb9d7d434ced5e72d773b2d..903490db3cf588364c9ff08098b1a9193438a7f3:/debian/rules?ds=inline

diff --git a/debian/rules b/debian/rules
index 70f28e1..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,34 +1,20 @@
 #!/usr/bin/make -f
 
-build: build-stamp
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
 
-build-stamp:
-	pod2man -n YOUTUBE-DL -c "User Commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	touch $@
+%:
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-clean:
-	dh_testdir
-	dh_clean build-stamp debian/youtube-dl.1
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-install: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k 
-	dh_install
+override_dh_clean:
+	test -f Makefile || mv Makefile.inactive Makefile
+	make clean
+	dh_clean
 
-binary-arch:
-binary-indep: build install
-	dh_testdir
-	dh_testroot
-	dh_installchangelogs 
-	dh_installdocs
-	dh_installman debian/youtube-dl.1
-	dh_compress
-	dh_fixperms
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: