X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/46ef599ac108f9d54c9d505ef1ac1c62dde6bbbe..39393b81acfaf4045fb7f20454a0226f0dc9142e:/debian/rules?ds=inline

diff --git a/debian/rules b/debian/rules
index cbe925d..e1e9a31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,21 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	rm youtube-dl
+
+override_dh_clean:
+	make clean
+	dh_clean
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+	make offlinetest PYTHON=python3
+endif