X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/479efb9c85e5c8a29ae1ffba5d69998a78938d8a..54d5fa9938f088c9610aaf81f3a90df4c2b1f956:/debian/rules

diff --git a/debian/rules b/debian/rules
index a192947..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,20 @@
 #!/usr/bin/make -f
-%:
-	dh $@
 
-override_dh_installman:
-	pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	dh_installman
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
+%:
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-override_dh_auto_build:
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-override_dh_python2:
+override_dh_clean:
+	test -f Makefile || mv Makefile.inactive Makefile
+	make clean
+	dh_clean
 
-override_dh_pysupport:
+override_dh_auto_test: