X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/53b0892e0d78dd874acb6e22ed3e8c3f9fe175a4..cb7160687b01e550b387edbd5518ac9fd1791e29:/debian/rules?ds=sidebyside

diff --git a/debian/rules b/debian/rules
index a192947..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,20 @@
 #!/usr/bin/make -f
-%:
-	dh $@
 
-override_dh_installman:
-	pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	dh_installman
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
+%:
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-override_dh_auto_build:
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-override_dh_python2:
+override_dh_clean:
+	test -f Makefile || mv Makefile.inactive Makefile
+	make clean
+	dh_clean
 
-override_dh_pysupport:
+override_dh_auto_test: