X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/7ea11bac6ea82010a8ce962977cf18da103c61d6..cb32b5fcf6f680ea9caf47919b33779491b79038:/debian/rules?ds=sidebyside

diff --git a/debian/rules b/debian/rules
index df85b00..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,20 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-override_dh_installman:
-	pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	dh_installman
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-override_dh_python2:
+override_dh_clean:
+	test -f Makefile || mv Makefile.inactive Makefile
+	make clean
+	dh_clean
 
-override_dh_pysupport:
+override_dh_auto_test: