X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/8117a6a851e00c8a50d5a6f20bfd326636b0c32f..4121346dfbb2b660ded98e98069857c7a50e381f:/debian/rules

diff --git a/debian/rules b/debian/rules
index f0c8e34..e1e9a31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,21 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	rm youtube-dl
+
+override_dh_clean:
+	make clean
+	dh_clean
 
-override_dh_installman:
-	pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	dh_installman
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+	make offlinetest PYTHON=python3
+endif