X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/96b6463fbe26a4414818425b6544faf73e169ed1..b74522ed28ebcae6e0e351f94735a3e7a70b3665:/debian/rules?ds=inline

diff --git a/debian/rules b/debian/rules
index 9031782..9c645f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,33 +1,17 @@
 #!/usr/bin/make -f
+%:
+	dh $@ --with python2 --buildsystem=python_distutils \
+		--with bash-completion
 
-build:
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-clean:
-	dh_testdir
-	dh_clean 
+override_dh_clean:
+	-mv Makefile.inactive Makefile
+	-make clean
+	dh_clean
+	rm -rf youtube_dl.egg-info
 
-install: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k 
-	dh_installdirs
-
-	install -m 0755 $(CURDIR)/youtube-dl $(CURDIR)/debian/youtube-dl/usr/bin
-
-binary-indep: build install
-
-binary-arch: build install
-	dh_testdir
-	dh_testroot
-	dh_installchangelogs 
-	dh_installdocs
-	dh_installman $(CURDIR)/debian/youtube-dl.1
-	dh_compress
-	dh_fixperms
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: