X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/ab22b64615ccad53c273bec2989802a3bef0625e..59ef81621ff3cb7e9391c44be06483bed7721031:/debian/rules?ds=inline

diff --git a/debian/rules b/debian/rules
index 8271a23..e1e9a31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,30 +1,21 @@
 #!/usr/bin/make -f
 
-build:
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
 
-clean:
-	dh_testdir
-	dh_clean 
+%:
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-install: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k 
-	dh_install
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	rm youtube-dl
 
-binary-arch:
-binary-indep: build install
-	dh_testdir
-	dh_testroot
-	dh_installchangelogs 
-	dh_installdocs
-	dh_installman debian/youtube-dl.1
-	dh_compress
-	dh_fixperms
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+override_dh_clean:
+	make clean
+	dh_clean
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+	make offlinetest PYTHON=python3
+endif