X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/b74522ed28ebcae6e0e351f94735a3e7a70b3665..6245a4128588146e39f66b371624ee39bdbb7720:/debian/rules

diff --git a/debian/rules b/debian/rules
index 9c645f1..e1e9a31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,17 +1,21 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@ --with python2 --buildsystem=python_distutils \
-		--with bash-completion
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
 override_dh_auto_configure:
 	PREFIX=/usr SYSCONFDIR=/etc make
-	mv Makefile Makefile.inactive
 	rm youtube-dl
 
 override_dh_clean:
-	-mv Makefile.inactive Makefile
-	-make clean
+	make clean
 	dh_clean
-	rm -rf youtube_dl.egg-info
 
 override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+	make offlinetest PYTHON=python3
+endif