X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/b74522ed28ebcae6e0e351f94735a3e7a70b3665..e070b5f283f0eca1a445b8382dd7292803ba2c3f:/debian/rules

diff --git a/debian/rules b/debian/rules
index 9c645f1..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,11 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@ --with python2 --buildsystem=python_distutils \
-		--with bash-completion
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
 override_dh_auto_configure:
 	PREFIX=/usr SYSCONFDIR=/etc make
@@ -9,9 +13,8 @@ override_dh_auto_configure:
 	rm youtube-dl
 
 override_dh_clean:
-	-mv Makefile.inactive Makefile
-	-make clean
+	test -f Makefile || mv Makefile.inactive Makefile
+	make clean
 	dh_clean
-	rm -rf youtube_dl.egg-info
 
 override_dh_auto_test: