X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/bd15199ded03c9c60ee785f280f561fda87b56d2..74a9312fb6565d0d3d227b6c959436678ce1dbe2:/debian/rules

diff --git a/debian/rules b/debian/rules
index b389392..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,20 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-override_dh_installman:
-	pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	dh_installman
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-override_dh_python2:
+override_dh_clean:
+	test -f Makefile || mv Makefile.inactive Makefile
+	make clean
+	dh_clean
 
-override_dh_pysupport:
 override_dh_auto_test: