X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/bd15199ded03c9c60ee785f280f561fda87b56d2..948e7e72e8c48fac09cc92b37abe001b421fda48:/debian/rules

diff --git a/debian/rules b/debian/rules
index b389392..e1e9a31 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,21 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-	dh $@
+	dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-override_dh_installman:
-	pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	dh_installman
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	rm youtube-dl
 
-override_dh_python2:
+override_dh_clean:
+	make clean
+	dh_clean
 
-override_dh_pysupport:
 override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+	make offlinetest PYTHON=python3
+endif