X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/beb6d38e0a0a4091007847a27022bf08c59f971c..b74522ed28ebcae6e0e351f94735a3e7a70b3665:/debian/rules

diff --git a/debian/rules b/debian/rules
index 07d43f2..9c645f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,16 +1,17 @@
 #!/usr/bin/make -f
 %:
-	dh $@ --with python2 --buildsystem=python_distutils
+	dh $@ --with python2 --buildsystem=python_distutils \
+		--with bash-completion
 
-override_dh_install:
-	mv debian/youtube-dl/usr/etc debian/youtube-dl/
-	dh_install
-
-override_dh_installdocs:
-	dh_installdocs
-	mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
-	rmdir debian/youtube-dl/usr/share/doc/youtube_dl
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
 override_dh_clean:
+	-mv Makefile.inactive Makefile
+	-make clean
 	dh_clean
 	rm -rf youtube_dl.egg-info
+
+override_dh_auto_test: