X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/c14c8740bfc1b94d4ec18f886c6e001acf171999..0008b00088b286af457b7a4ee7a072a7ed590db3:/debian/rules

diff --git a/debian/rules b/debian/rules
index 70f28e1..07d43f2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,34 +1,16 @@
 #!/usr/bin/make -f
+%:
+	dh $@ --with python2 --buildsystem=python_distutils
 
-build: build-stamp
-
-build-stamp:
-	pod2man -n YOUTUBE-DL -c "User Commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	touch $@
-
-clean:
-	dh_testdir
-	dh_clean build-stamp debian/youtube-dl.1
-
-install: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k 
+override_dh_install:
+	mv debian/youtube-dl/usr/etc debian/youtube-dl/
 	dh_install
 
-binary-arch:
-binary-indep: build install
-	dh_testdir
-	dh_testroot
-	dh_installchangelogs 
+override_dh_installdocs:
 	dh_installdocs
-	dh_installman debian/youtube-dl.1
-	dh_compress
-	dh_fixperms
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+	mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
+	rmdir debian/youtube-dl/usr/share/doc/youtube_dl
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_clean:
+	dh_clean
+	rm -rf youtube_dl.egg-info