X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/c14c8740bfc1b94d4ec18f886c6e001acf171999..b74522ed28ebcae6e0e351f94735a3e7a70b3665:/debian/rules

diff --git a/debian/rules b/debian/rules
index 70f28e1..9c645f1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,34 +1,17 @@
 #!/usr/bin/make -f
+%:
+	dh $@ --with python2 --buildsystem=python_distutils \
+		--with bash-completion
 
-build: build-stamp
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
 
-build-stamp:
-	pod2man -n YOUTUBE-DL -c "User Commands" debian/youtube-dl.pod > debian/youtube-dl.1
-	touch $@
+override_dh_clean:
+	-mv Makefile.inactive Makefile
+	-make clean
+	dh_clean
+	rm -rf youtube_dl.egg-info
 
-clean:
-	dh_testdir
-	dh_clean build-stamp debian/youtube-dl.1
-
-install: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k 
-	dh_install
-
-binary-arch:
-binary-indep: build install
-	dh_testdir
-	dh_testroot
-	dh_installchangelogs 
-	dh_installdocs
-	dh_installman debian/youtube-dl.1
-	dh_compress
-	dh_fixperms
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: