X-Git-Url: https://git.rapsys.eu/youtubedl/blobdiff_plain/c705a91c64059c7d2724e0c3ca2359afee2f592a..b13d4a493050b321e8e726718779a56c4899c51e:/debian/rules

diff --git a/debian/rules b/debian/rules
index cbe925d..8700969 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,31 @@
 #!/usr/bin/make -f
 %:
-	dh $@
+	dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_auto_configure:
+	PREFIX=/usr SYSCONFDIR=/etc make
+	mv Makefile Makefile.inactive
+	rm youtube-dl
+
+override_dh_install:
+	mv debian/youtube-dl/usr/etc debian/youtube-dl/
+#	# For the future (similarly for fish):
+#	# dpkg-maintscript-helper rm_conffile /etc/youtube-dl.bash-completion \
+#	#   etc.
+#
+#	mv debian/youtube-dl/usr/etc/bash_completion.d/youtube-dl.bash-completion \
+#		debian/usr/share/bash-completion/completions/youtube-dl
+	dh_install
+
+override_dh_installdocs:
+	dh_installdocs
+	mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
+	rmdir debian/youtube-dl/usr/share/doc/youtube_dl
+
+override_dh_clean:
+	-mv Makefile.inactive Makefile
+	-make clean
+	dh_clean
+	rm -rf youtube_dl.egg-info
+
+override_dh_auto_test: