Reorder require
[airlibre] / composer.json
index 86e6ea9..3b1ab4c 100644 (file)
@@ -1,7 +1,7 @@
 {
     "type": "project",
     "name": "rapsys/airlibre",
-    "description": "Open air booking system",
+    "description": "Outdoor area booking system",
     "license": "AGPL-3.0-or-later",
     "require": {
         "php": "^7.1.3",
         "rapsys/airbundle": "dev-master",
         "rapsys/packbundle": "dev-master",
         "rapsys/userbundle": "dev-master",
-        "symfony/config": "4.3.*",
-        "symfony/console": "4.3.*",
-        "symfony/dependency-injection": "4.3.*",
-        "symfony/dotenv": "4.3.*",
-        "symfony/flex": "^1.3.1",
-        "symfony/framework-bundle": "4.3.*",
-        "symfony/process": "4.3.*",
-        "symfony/security": "4.3.*",
-        "symfony/yaml": "4.3.*"
+        "symfony/asset": "^4.4",
+        "symfony/console": "^4.4",
+        "symfony/dependency-injection": "^4.4",
+        "symfony/dom-crawler": "^4.4",
+        "symfony/dotenv": "^4.4",
+        "symfony/filesystem": "^4.4",
+        "symfony/finder": "^4.4",
+        "symfony/flex": "^1.5",
+        "symfony/framework-bundle": "^4.4",
+        "symfony/http-foundation": "^4.4",
+        "symfony/inflector": "^4.4",
+        "symfony/intl": "^4.4",
+        "symfony/mime": "^4.4",
+        "symfony/options-resolver": "^4.4",
+        "symfony/process": "^4.4",
+        "symfony/property-access": "^4.4",
+        "symfony/security-bundle": "^4.4",
+        "symfony/security-csrf": "^4.4",
+        "symfony/stopwatch": "^4.4",
+        "symfony/var-dumper": "^4.4",
+        "symfony/var-exporter": "^4.4",
+        "symfony/yaml": "^4.4",
+        "twig/extensions": "^1.5"
     },
     "require-dev": {
+        "doctrine/doctrine-fixtures-bundle": "^3.3",
+        "symfony/browser-kit": "^4.4",
+        "symfony/maker-bundle": "^1.14",
+        "symfony/phpunit-bridge": "^4.4",
+        "symfony/web-profiler-bundle": "^4.4"
     },
     "config": {
         "preferred-install": {
             "App\\Tests\\": "tests/"
         }
     },
+    "repositories": [
+        {
+            "type": "package",
+            "package": {
+                "name": "rapsys/userbundle",
+                "version": "dev-master",
+                "source": {
+                    "type": "git",
+                    "url": "https://rapsys@git.rapsys.eu/userbundle",
+                    "reference": "master"
+                },
+                "autoload": {
+                    "psr-4": {
+                        "Rapsys\\UserBundle\\": ""
+                    }
+                },
+                "require": {
+                    "doctrine/doctrine-bundle": "^1.12",
+                    "symfony/flex": "^1.5",
+                    "symfony/form": "^4.4",
+                    "symfony/framework-bundle": "^4.4",
+                    "symfony/security-bundle": "^4.4",
+                    "symfony/validator": "^4.4"
+                }
+            }
+        },
+        {
+            "type": "package",
+            "package": {
+                "name": "rapsys/packbundle",
+                "version": "dev-master",
+                "source": {
+                    "type": "git",
+                    "url": "https://rapsys@git.rapsys.eu/packbundle",
+                    "reference": "master"
+                },
+                "autoload": {
+                    "psr-4": {
+                        "Rapsys\\PackBundle\\": ""
+                    }
+                },
+                "require": {
+                    "symfony/asset": "^4.4",
+                    "symfony/flex": "^1.5",
+                    "symfony/framework-bundle": "^4.4",
+                    "symfony/process": "^4.4",
+                    "symfony/twig-bundle": "^4.4",
+                    "twig/extensions": "^1.5"
+                }
+            }
+        },
+        {
+            "type": "package",
+            "package": {
+                "name": "rapsys/airbundle",
+                "version": "dev-master",
+                "source": {
+                    "type": "git",
+                    "url": "https://rapsys@git.rapsys.eu/airbundle",
+                    "reference": "master"
+                },
+                "autoload": {
+                    "psr-4": {
+                        "Rapsys\\AirBundle\\": ""
+                    }
+                },
+                "require": {
+                    "doctrine/doctrine-bundle": "^1.12",
+                    "doctrine/orm": "^2.7",
+                    "symfony/flex": "^1.5",
+                    "symfony/form": "^4.4",
+                    "symfony/framework-bundle": "^4.4",
+                    "symfony/mailer": "^4.4",
+                    "symfony/profiler-pack": "^1.0",
+                    "symfony/security-bundle": "^4.4",
+                    "symfony/translation": "^4.4",
+                    "symfony/twig-bundle": "^4.4",
+                    "symfony/validator": "^4.4",
+                    "twig/extensions": "^1.5",
+                    "twig/html-extra": "^2.12"
+                },
+                "require-dev": {
+                    "doctrine/doctrine-fixtures-bundle": "^3.3",
+                    "symfony/browser-kit": "^4.3",
+                    "symfony/maker-bundle": "^1.14",
+                    "symfony/phpunit-bridge": "^4.4",
+                    "symfony/web-profiler-bundle": "^4.4"
+                }
+            }
+        }
+    ],
     "replace": {
         "paragonie/random_compat": "2.*",
         "symfony/polyfill-ctype": "*",
         "symfony/polyfill-php70": "*",
         "symfony/polyfill-php56": "*"
     },
-    "repositories": [
-           {
-                   "type": "package",
-                   "package": {
-                           "name": "rapsys/userbundle",
-                           "version": "dev-master",
-                           "source": {
-                                   "type": "git",
-                                   "url": "https://rapsys@git.rapsys.eu/userbundle",
-                                   "reference": "master"
-                           },
-                           "autoload": {
-                                   "psr-4": {
-                                           "Rapsys\\UserBundle\\": ""
-                                   }
-                           }
-                   }
-           },
-           {
-                   "type": "package",
-                   "package": {
-                           "name": "rapsys/packbundle",
-                           "version": "dev-master",
-                           "source": {
-                                   "type": "git",
-                                   "url": "https://rapsys@git.rapsys.eu/packbundle",
-                                   "reference": "master"
-                           },
-                           "autoload": {
-                                   "psr-4": {
-                                           "Rapsys\\PackBundle\\": ""
-                                   }
-                           }
-                   }
-           },
-           {
-                   "type": "package",
-                   "package": {
-                           "name": "rapsys/airbundle",
-                           "version": "dev-master",
-                           "source": {
-                                   "type": "git",
-                                   "url": "https://rapsys@git.rapsys.eu/airbundle",
-                                   "reference": "master"
-                           },
-                           "autoload": {
-                                   "psr-4": {
-                                           "Rapsys\\AirBundle\\": ""
-                                   }
-                           }
-                   }
-           }
-    ],
     "scripts": {
         "auto-scripts": {
             "cache:clear": "symfony-cmd",
     "extra": {
         "symfony-assets-install": "relative",
         "incenteev-parameters": {
-            "file": "app/config/parameters.yml",
-           "keep-outdated": true
+            "keep-outdated": true
         },
         "symfony": {
-            "allow-contrib": false,
-            "require": "4.3.*"
+            "allow-contrib": true,
+            "endpoint": "https://flex.rapsys.eu"
         }
     }
 }