%{?!serverlimit:%global serverlimit 1024}
Name: ihttpd
-Version: 2.4.33
-Release: %mkrel 5
+Version: 2.4.38
+Release: %mkrel 6
Summary: The most widely used Web server on the Internet
License: Apache License
Group: System/Servers
Source0: http://www.apache.org/dist/httpd/httpd-%version.tar.bz2
Source1: index.bin.c
Source2: reboot.sh
-Source14: ihttpd.tmpfiles
Source15: ihttpd.service
Source16: debug-sshd.service
Source18: ihttpd.dracut
Patch20: httpd-2.4.3-release.patch
#Patch23: httpd-2.4.4-export.patch
Patch24: httpd-2.4.1-corelimit.patch
-Patch26: httpd-2.4.4-r1337344+.patch
+#Patch26: httpd-2.4.4-r1337344+.patch
Patch27: httpd-2.4.2-icons.patch
Patch28: httpd-2.4.4-r1332643+.patch
Patch30: httpd-2.4.4-cachehardmax.patch
#Patch31: httpd-2.4.18-sslmultiproxy.patch
Patch34: httpd-2.4.33-socket-activation.patch
-Patch35: httpd-2.4.33-sslciphdefault.patch
+#Patch35: httpd-2.4.33-sslciphdefault.patch
# Bug fixes
#Patch55: httpd-2.4.4-malformed-host.patch
#Patch56: httpd-2.4.4-mod_unique_id.patch
Requires(post): openssl makedev
Requires(preun): rpm-helper >= 0.24.8-1
+BuildRequires: apr-devel apr-util-devel
+
%description
This package contains the main binary of apache, a powerful, full-featured,
efficient and freely-available Web server. Apache is also the most popular Web
#%patch23 -p1 -b .export
%patch24 -p1 -b .corelimit
-%patch26 -p1 -b .r1337344+
+#%patch26 -p1 -b .r1337344+
%patch27 -p1 -b .icons
%patch30 -p1 -b .cachehardmax
#%patch31 -p1 -b .sslmultiproxy
%patch34 -p1 -b .socketactivation
-%patch35 -p1 -b .sslciphdefault
+#%patch35 -p1 -b .sslciphdefault
#%patch55 -p1 -b .malformedhost
#%patch56 -p1 -b .uniqueid
# Hard-code path to links to avoid unnecessary builddep
export LYNX_PATH=/usr/bin/links
-%configure2_5x \
+%configure \
--enable-layout=IHttpd \
--sysconfdir='/etc' \
--includedir='/usr/include/ihttpd' \
--enable-modules=none \
--enable-mods-static='unixd auth_basic authn_core authn_file authz_core authz_host authz_user rewrite socache_shmcb dir mime log_config cgi ssl'
-%make
+%make_build
export CFLAGS="$RPM_OPT_FLAGS"
gcc index.bin.c -o index.bin
#IHttpd sbin
install -D -p -m 755 ihttpd %{buildroot}%{_sbindir}/ihttpd
-#Tmpfiles.d config
-install -D -p -m 644 %{SOURCE14} %{buildroot}%{_tmpfilesdir}/ihttpd.conf
-
#IHttpd dracut config
install -D -p -m 644 %{SOURCE18} %{buildroot}%{_sysconfdir}/dracut.conf.d/99-%{name}.conf
#%find_lang %name
%post
-%_tmpfilescreate %{name}
%_create_ssl_certificate %{name}
%files -n %name
%config(noreplace) %{_prefix}/lib/%{name}/%{name}.conf
%config(noreplace) %{_sysconfdir}/dracut.conf.d/99-%{name}.conf
%{_sbindir}/%{name}
-%{_tmpfilesdir}/%{name}.conf
%dir %{_prefix}/lib/dracut/modules.d/99ihttpd
%{_prefix}/lib/dracut/modules.d/99ihttpd/module-setup.sh
%dir %{_prefix}/lib/%{name}