]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Tidy up cleanup rule and keep lintian happy.
[youtubedl] / debian / rules
index 8271a237e289a0034daf42dd18cb0feb69bfe6a9..3efd20e1e7d5d89ef75911917e4bf66a5cf3fad7 100755 (executable)
@@ -1,30 +1,16 @@
 #!/usr/bin/make -f
+%:
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
 
-build:
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
 
-clean:
-       dh_testdir
-       dh_clean 
+override_dh_clean:
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
+       dh_clean
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_install
-
-binary-arch:
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman debian/youtube-dl.1
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: