]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Merge tag 'upstream/2016.08.17'
[youtubedl] / debian / rules
index 07d43f26b0a2513bc8eeb08166cc447b15d8de1b..870096940b3c124ddca977ba9296b502ad0ff962 100755 (executable)
@@ -2,8 +2,19 @@
 %:
        dh $@ --with python2 --buildsystem=python_distutils
 
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
 override_dh_install:
        mv debian/youtube-dl/usr/etc debian/youtube-dl/
+#      # For the future (similarly for fish):
+#      # dpkg-maintscript-helper rm_conffile /etc/youtube-dl.bash-completion \
+#      #   etc.
+#
+#      mv debian/youtube-dl/usr/etc/bash_completion.d/youtube-dl.bash-completion \
+#              debian/usr/share/bash-completion/completions/youtube-dl
        dh_install
 
 override_dh_installdocs:
@@ -12,5 +23,9 @@ override_dh_installdocs:
        rmdir debian/youtube-dl/usr/share/doc/youtube_dl
 
 override_dh_clean:
+       -mv Makefile.inactive Makefile
+       -make clean
        dh_clean
        rm -rf youtube_dl.egg-info
+
+override_dh_auto_test: