Rapsys Git
/
youtubedl
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
d/p/skip-style-checks-for-flake8: Add metadata to please lintian.
[youtubedl]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 344b8ae039344851c5741772ccda4e0b4047732e..e1e9a31437d6d1d4a3eda5e3016d0ae1dd753520 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-1,11
+1,21
@@
#!/usr/bin/make -f
#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
%:
%:
- dh $@ --
buildsystem=python_distutils
+ dh $@ --
with python3 --buildsystem=pybuild --with bash-completion
-override_dh_
install
:
- mv debian/youtube-dl/usr/etc debian/youtube-dl/
-
dh_instal
l
+override_dh_
auto_configure
:
+ PREFIX=/usr SYSCONFDIR=/etc make
+
rm youtube-d
l
override_dh_clean:
override_dh_clean:
+ make clean
dh_clean
dh_clean
- rm -rf youtube_dl.egg-info
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ make offlinetest PYTHON=python3
+endif