]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
d/control: Build-depend on flake8 and python3-nose.
[youtubedl] / debian / rules
index a1929472ca0f6c28bc061eba168b86f2c9fa322d..82d26cbeb20215b18fae35212f3ffda59d764b78 100755 (executable)
@@ -1,13 +1,20 @@
 #!/usr/bin/make -f
-%:
-       dh $@
 
-override_dh_installman:
-       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-       dh_installman
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
+%:
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-override_dh_auto_build:
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
 
-override_dh_python2:
+override_dh_clean:
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
+       dh_clean
 
-override_dh_pysupport:
+override_dh_auto_test: