]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
debian/changelog: Annotate with bug being closed.
[youtubedl] / debian / rules
index 3ee2eb64cfc2da0fd5a5e7e95bc018ffa22f7c8c..82d26cbeb20215b18fae35212f3ffda59d764b78 100755 (executable)
@@ -1,7 +1,20 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@ --buildsystem=python_distutils
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_clean:
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
+       dh_clean
 
-override_dh_install:
-       mv debian/youtube-dl/usr/etc debian/youtube-dl/
-       dh_install
+override_dh_auto_test: