]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Tidy up cleanup rule and keep lintian happy.
[youtubedl] / debian / rules
index 3ee2eb64cfc2da0fd5a5e7e95bc018ffa22f7c8c..3efd20e1e7d5d89ef75911917e4bf66a5cf3fad7 100755 (executable)
@@ -1,7 +1,16 @@
 #!/usr/bin/make -f
 %:
-       dh $@ --buildsystem=python_distutils
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
 
-override_dh_install:
-       mv debian/youtube-dl/usr/etc debian/youtube-dl/
-       dh_install
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_clean:
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
+       dh_clean
+
+override_dh_auto_test: