Rapsys Git
/
youtubedl
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Update changelog.
[youtubedl]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 3ee2eb64cfc2da0fd5a5e7e95bc018ffa22f7c8c..e1e9a31437d6d1d4a3eda5e3016d0ae1dd753520 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-1,7
+1,21
@@
#!/usr/bin/make -f
#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
%:
%:
- dh $@ --buildsystem=python_distutils
+ dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+ PREFIX=/usr SYSCONFDIR=/etc make
+ rm youtube-dl
+
+override_dh_clean:
+ make clean
+ dh_clean
-override_dh_install:
- mv debian/youtube-dl/usr/etc debian/youtube-dl/
- dh_install
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ make offlinetest PYTHON=python3
+endif