]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Merge tag 'upstream/2012.02.27+gita171dbf'
[youtubedl] / debian / rules
index 70f28e15a73fe7bf0ae17510ce23a6b3bc06de4e..a1929472ca0f6c28bc061eba168b86f2c9fa322d 100755 (executable)
@@ -1,34 +1,13 @@
 #!/usr/bin/make -f
+%:
+       dh $@
 
-build: build-stamp
+override_dh_installman:
+       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
+       dh_installman
 
-build-stamp:
-       pod2man -n YOUTUBE-DL -c "User Commands" debian/youtube-dl.pod > debian/youtube-dl.1
-       touch $@
+override_dh_auto_build:
 
-clean:
-       dh_testdir
-       dh_clean build-stamp debian/youtube-dl.1
+override_dh_python2:
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_install
-
-binary-arch:
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman debian/youtube-dl.1
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_pysupport: