]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
debian/watch: Adapt for mangled debian version.
[youtubedl] / debian / rules
index 70f28e15a73fe7bf0ae17510ce23a6b3bc06de4e..504e3570fc9b5df3cb3a4e906663cb3df6e6ecca 100755 (executable)
@@ -1,34 +1,32 @@
 #!/usr/bin/make -f
+%:
+       dh $@
 
-build: build-stamp
-
-build-stamp:
-       pod2man -n YOUTUBE-DL -c "User Commands" debian/youtube-dl.pod > debian/youtube-dl.1
-       touch $@
-
-clean:
-       dh_testdir
-       dh_clean build-stamp debian/youtube-dl.1
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_install
-
-binary-arch:
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman debian/youtube-dl.1
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_installman:
+       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
+       dh_installman
+
+override_dh_python2:
+
+override_dh_pysupport:
+
+
+FULL_VERSION   := $(shell dpkg-parsechangelog | grep ^Version: | sed -e 's/^.*: //g')
+TAR_VERSION    := $(shell echo $(FULL_VERSION) | sed -e 's/-.*//g')
+SOURCE         := $(shell dpkg-parsechangelog | grep ^Source: | sed -e 's/^.*: //g')
+
+ORIGDIR        = $(SOURCE)-$(TAR_VERSION)
+TARNAME        = $(SOURCE)_$(TAR_VERSION).orig.tar.gz
+
+get-orig-source:
+       rm -rf repack
+       mkdir -p repack/$(ORIGDIR)
+
+       uscan --noconf --force-download --rename --download-current-version --destdir=repack/
+       cd repack; tar zxf $(TARNAME)
+
+       # Remove problematic files
+       rm -f repack/$(ORIGDIR)/youtube-dl.exe
+
+       tar -C repack --numeric-owner --owner 0 --group 0 -czf ../$(TARNAME) $(ORIGDIR)
+       rm -rf repack