]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Tidy up cleanup rule and keep lintian happy.
[youtubedl] / debian / rules
index cbe925d7587131c8ec8761915930894c60c096fd..3efd20e1e7d5d89ef75911917e4bf66a5cf3fad7 100755 (executable)
@@ -1,3 +1,16 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
+
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_clean:
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
+       dh_clean
+
+override_dh_auto_test: