#!/usr/bin/make -f
-%:
- dh $@
-
-override_dh_installman:
- pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
- dh_installman
-
-override_dh_python2:
-
-override_dh_pysupport:
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
-FULL_VERSION := $(shell dpkg-parsechangelog | grep ^Version: | sed -e 's/^.*: //g')
-TAR_VERSION := $(shell echo $(FULL_VERSION) | sed -e 's/-.*//g')
-SOURCE := $(shell dpkg-parsechangelog | grep ^Source: | sed -e 's/^.*: //g')
-
-ORIGDIR = $(SOURCE)-$(TAR_VERSION)
-TARNAME = $(SOURCE)_$(TAR_VERSION).orig.tar.gz
-
-get-orig-source:
- rm -rf repack
- mkdir -p repack/$(ORIGDIR)
+%:
+ dh $@ --with python3 --buildsystem=pybuild --with bash-completion
- uscan --noconf --force-download --rename --download-current-version --destdir=repack/
- cd repack; tar zxf $(TARNAME)
+override_dh_auto_configure:
+ PREFIX=/usr SYSCONFDIR=/etc make
+ mv Makefile Makefile.inactive
+ rm youtube-dl
- # Remove problematic files
- rm -f repack/$(ORIGDIR)/youtube-dl.exe
+override_dh_clean:
+ test -f Makefile || mv Makefile.inactive Makefile
+ make clean
+ dh_clean
- tar -C repack --numeric-owner --owner 0 --group 0 -czf ../$(TARNAME) $(ORIGDIR)
- rm -rf repack
+override_dh_auto_test: