]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Merge tag 'upstream/2016.08.17'
[youtubedl] / debian / rules
index 504e3570fc9b5df3cb3a4e906663cb3df6e6ecca..870096940b3c124ddca977ba9296b502ad0ff962 100755 (executable)
@@ -1,32 +1,31 @@
 #!/usr/bin/make -f
 %:
-       dh $@
-
-override_dh_installman:
-       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-       dh_installman
-
-override_dh_python2:
-
-override_dh_pysupport:
-
-
-FULL_VERSION   := $(shell dpkg-parsechangelog | grep ^Version: | sed -e 's/^.*: //g')
-TAR_VERSION    := $(shell echo $(FULL_VERSION) | sed -e 's/-.*//g')
-SOURCE         := $(shell dpkg-parsechangelog | grep ^Source: | sed -e 's/^.*: //g')
-
-ORIGDIR        = $(SOURCE)-$(TAR_VERSION)
-TARNAME        = $(SOURCE)_$(TAR_VERSION).orig.tar.gz
-
-get-orig-source:
-       rm -rf repack
-       mkdir -p repack/$(ORIGDIR)
-
-       uscan --noconf --force-download --rename --download-current-version --destdir=repack/
-       cd repack; tar zxf $(TARNAME)
-
-       # Remove problematic files
-       rm -f repack/$(ORIGDIR)/youtube-dl.exe
-
-       tar -C repack --numeric-owner --owner 0 --group 0 -czf ../$(TARNAME) $(ORIGDIR)
-       rm -rf repack
+       dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_install:
+       mv debian/youtube-dl/usr/etc debian/youtube-dl/
+#      # For the future (similarly for fish):
+#      # dpkg-maintscript-helper rm_conffile /etc/youtube-dl.bash-completion \
+#      #   etc.
+#
+#      mv debian/youtube-dl/usr/etc/bash_completion.d/youtube-dl.bash-completion \
+#              debian/usr/share/bash-completion/completions/youtube-dl
+       dh_install
+
+override_dh_installdocs:
+       dh_installdocs
+       mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
+       rmdir debian/youtube-dl/usr/share/doc/youtube_dl
+
+override_dh_clean:
+       -mv Makefile.inactive Makefile
+       -make clean
+       dh_clean
+       rm -rf youtube_dl.egg-info
+
+override_dh_auto_test: