]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
d/rules: Run offline tests.
[youtubedl] / debian / rules
index f0c8e341ab636fe3c9855e53eea32aea767b9cfe..e1e9a31437d6d1d4a3eda5e3016d0ae1dd753520 100755 (executable)
@@ -1,7 +1,21 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       rm youtube-dl
+
+override_dh_clean:
+       make clean
+       dh_clean
 
-override_dh_installman:
-       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-       dh_installman
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+       make offlinetest PYTHON=python3
+endif