]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
d/rules: Drop makefile mangling
[youtubedl] / debian / rules
index f0c8e341ab636fe3c9855e53eea32aea767b9cfe..541ff15d881fd7e8b70fef3a40fba5e0d18fec84 100755 (executable)
@@ -1,7 +1,18 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       rm youtube-dl
+
+override_dh_clean:
+       make clean
+       dh_clean
 
-override_dh_installman:
-       pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
-       dh_installman
+override_dh_auto_test: