Rapsys Git
/
youtubedl
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Adapt changes from Andreas Tille for porting to Salsa.
[youtubedl]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index df85b00c72a49f2e05b8586e376da2e045146bbc..82d26cbeb20215b18fae35212f3ffda59d764b78 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-1,11
+1,20
@@
#!/usr/bin/make -f
#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
%:
%:
- dh $@
+ dh $@
--with python3 --buildsystem=pybuild --with bash-completion
-override_dh_installman:
- pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
- dh_installman
+override_dh_auto_configure:
+ PREFIX=/usr SYSCONFDIR=/etc make
+ mv Makefile Makefile.inactive
+ rm youtube-dl
-override_dh_python2:
+override_dh_clean:
+ test -f Makefile || mv Makefile.inactive Makefile
+ make clean
+ dh_clean
-override_dh_
pysuppor
t:
+override_dh_
auto_tes
t: