Rapsys Git
/
youtubedl
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Update changelog.
[youtubedl]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index df85b00c72a49f2e05b8586e376da2e045146bbc..e1e9a31437d6d1d4a3eda5e3016d0ae1dd753520 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-1,11
+1,21
@@
#!/usr/bin/make -f
#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
%:
%:
- dh $@
+ dh $@
--with python3 --buildsystem=pybuild --with bash-completion
-override_dh_
installman
:
- pod2man -r "youtube-dl" -c "User commands" debian/youtube-dl.pod > debian/youtube-dl.1
- dh_installman
+override_dh_
auto_configure
:
+ PREFIX=/usr SYSCONFDIR=/etc make
+ rm youtube-dl
-override_dh_python2:
+override_dh_clean:
+ make clean
+ dh_clean
-override_dh_pysupport:
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ make offlinetest PYTHON=python3
+endif