]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Update upstream source from tag 'upstream/2019.09.28'
[youtubedl] / debian / rules
index 73b842f39f4d4dab5ae6255e7e2c27794331e431..82d26cbeb20215b18fae35212f3ffda59d764b78 100755 (executable)
@@ -1,23 +1,20 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@ --with python2 --buildsystem=python_distutils
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
 override_dh_auto_configure:
        PREFIX=/usr SYSCONFDIR=/etc make
        mv Makefile Makefile.inactive
        rm youtube-dl
 
-override_dh_install:
-       mv debian/youtube-dl/usr/etc debian/youtube-dl/
-       dh_install
-
-override_dh_installdocs:
-       dh_installdocs
-       mv debian/youtube-dl/usr/share/doc/youtube_dl/* debian/youtube-dl/usr/share/doc/youtube-dl
-       rmdir debian/youtube-dl/usr/share/doc/youtube_dl
-
 override_dh_clean:
-       -mv Makefile.inactive Makefile
-       -make clean
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
        dh_clean
-       rm -rf youtube_dl.egg-info
+
+override_dh_auto_test: