Rapsys Git
/
youtubedl
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
debian/{compat,control}: Relutanctly update compat to 11.
[youtubedl]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index 4bf82f553e397edddf11732fc317e347b8e9cc16..82d26cbeb20215b18fae35212f3ffda59d764b78 100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-1,9
+1,20
@@
#!/usr/bin/make -f
#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
%:
%:
- dh $@
+ dh $@
--with python3 --buildsystem=pybuild --with bash-completion
-override_dh_python2:
+override_dh_auto_configure:
+ PREFIX=/usr SYSCONFDIR=/etc make
+ mv Makefile Makefile.inactive
+ rm youtube-dl
-override_dh_pysupport:
+override_dh_clean:
+ test -f Makefile || mv Makefile.inactive Makefile
+ make clean
+ dh_clean
override_dh_auto_test:
override_dh_auto_test: