]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
d/rules: Drop makefile mangling
[youtubedl] / debian / rules
index 328323eaabe5d6847fc5fb55402ef4cc70265144..541ff15d881fd7e8b70fef3a40fba5e0d18fec84 100755 (executable)
@@ -1,5 +1,18 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
+
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       rm youtube-dl
+
+override_dh_clean:
+       make clean
+       dh_clean
 
 override_dh_auto_test: