]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Tidy up cleanup rule and keep lintian happy.
[youtubedl] / debian / rules
index 328323eaabe5d6847fc5fb55402ef4cc70265144..3efd20e1e7d5d89ef75911917e4bf66a5cf3fad7 100755 (executable)
@@ -1,5 +1,16 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       dh $@ --with python2 --buildsystem=python_distutils \
+               --with bash-completion
+
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
+
+override_dh_clean:
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
+       dh_clean
 
 override_dh_auto_test: