]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
debian/copyright: Use HTTPS for upstream's source.
[youtubedl] / debian / rules
index 8271a237e289a0034daf42dd18cb0feb69bfe6a9..82d26cbeb20215b18fae35212f3ffda59d764b78 100755 (executable)
@@ -1,30 +1,20 @@
 #!/usr/bin/make -f
 
-build:
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
 
-clean:
-       dh_testdir
-       dh_clean 
+%:
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_install
+override_dh_auto_configure:
+       PREFIX=/usr SYSCONFDIR=/etc make
+       mv Makefile Makefile.inactive
+       rm youtube-dl
 
-binary-arch:
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installman debian/youtube-dl.1
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+override_dh_clean:
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
+       dh_clean
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+override_dh_auto_test: