]> Raphaƫl G. Git Repositories - youtubedl/blobdiff - debian/rules
Prepare upload.
[youtubedl] / debian / rules
index 9c645f1c863c90c91a71d29ad84cb96a3d6d86dd..82d26cbeb20215b18fae35212f3ffda59d764b78 100755 (executable)
@@ -1,7 +1,11 @@
 #!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
 %:
-       dh $@ --with python2 --buildsystem=python_distutils \
-               --with bash-completion
+       dh $@ --with python3 --buildsystem=pybuild --with bash-completion
 
 override_dh_auto_configure:
        PREFIX=/usr SYSCONFDIR=/etc make
@@ -9,9 +13,8 @@ override_dh_auto_configure:
        rm youtube-dl
 
 override_dh_clean:
-       -mv Makefile.inactive Makefile
-       -make clean
+       test -f Makefile || mv Makefile.inactive Makefile
+       make clean
        dh_clean
-       rm -rf youtube_dl.egg-info
 
 override_dh_auto_test: